Le forum francophone des clients FTP, et de LeechFTP en particulier

 
 
Le forum francophone des clients FTP, et de LeechFTP en particulier » Les clients FTP » LeechFTP » Problème dossier admin + petite question
Connexions
1 connecté(s) sur le forum actuellement: 0 membre(s) | 1 invité(s)
 
 
 
<<Sujet précédent     Sujet suivant>>


 
 
Auteur Imprimer le topic Message

 
 
jules34

Nouveau

Enregistré le 12/06/2007
Messages: 6
Non connecté

Sujet : Problème dossier admin + petite question
Ajouté le : 12/06/2007 22:48
Message :

Bonsoir à tous,

Je me présente vite fais : moi c'est Julien 20 ans et je vie dans le sud de la France.
Je suis tombé sur ce forum en cherchant des explications à mon problème sur google.

Je m'explique : j'ai envoyé mes fichiers/dossiers avec leechftp sur le serveur claranet, jusqu'a la tout va bien

Le truc c'est que j'ai crée un dossier admin sécurisé par un login et mot de passe pour pouvoir travailler sur la base de données par la suite. Mais quand je télécharge le dossier admin sur le serveur et que j'essai d'y accèder en tapant le login et le mot de passe il me demande de le retaper comme si ce n'était pes les bons
J'ai bien tenté de le placer dans le dossier sécurity mais ça ne change rien.


Je me demandais s'il fallait placer le dossier à un endroit spécial ou bien changer quelque chose.
J'espère mettre fait compris et merci d'avance pour vos réponses

édit : Tiens tant qu'à faire je vais vous poser une petite question aussi : certaines images ne s'affichent pas sur mon site. Je pensais que ça venait du dossier ou que les liens n'étaient pas correct mais non. Certaines photos s'affichent et pas d'autres. D'où peut venir le problèmes ? Le poids ?

*** Message édité par jules34 le 12/06/2007 22:51 ***

Recharger l'url avec lien direct vers ce message Imprimer le message Aller en bas de page Aller en haut de page Editez ce post (réservé aux modérateurs) Avertissez l'administrateur si le post est non conventionnel Envoyer un email à jules34!!! Envoyer un Message Privé à jules34 Citer ce post dans votre réponse

 
 
admin

Nouveau

Enregistré le 20/05/2007
Messages: 26
Non connecté

Ajouté le : 12/06/2007 23:36
Message :

Bonsoir jules34,

concernant le problème du dossier protéger, il survient très certainement parce que l'hébergement est de type unix
pour résoudre ce problème que j'ai déjà eu, voici comment je fais :
- je renomme les fichiers .htaccess en htaccess.txt et .htpasswd en htpasswd.txt
- j'envoie les fichiers sur le serveur dans le dossier protégé
- je renomme les fichiers distant (clic-droit+renommer dans la partie droite de leechftp) pour leur redonner leur noms d'origine
- ensuite j'envoie le reste du contenu du dossier admin

pourquoi ? simplement parce que leechftp gère tout seul la conversion au format unix des fichiers transférés, à condition qu'ils aient l'extention .txt

sinon une autre solution c'est de créer les fichiers de protection avec un éditeur de texte capable d'enregistrer directement au format unix (comme par exemple html-kit)

Bonne chance !


Coup de pouce aux amis :
Votre site en page 1 sur Google
Autorépondeur gratuit et en français
Alerte twitter par mail
2 millions de visiteurs gratuitement pour votre site
Recharger l'url avec lien direct vers ce message Imprimer le message Aller en bas de page Aller en haut de page Editez ce post (réservé aux modérateurs) Avertissez l'administrateur si le post est non conventionnel Envoyer un email à admin!!! Visitez le site de admin!! Envoyer un Message Privé à admin Citer ce post dans votre réponse

 
 
jules34

Nouveau

Enregistré le 12/06/2007
Messages: 6
Non connecté

Ajouté le : 13/06/2007 09:34
Message :

Bon tout d'abord merci de ta réponses, je vais essayer tout ça maintenant.

J'avais quelques petites questions quand même :
- quand tu dis "j'envoie les fichiers sur le serveur dans le dossier protégé" c'est que les fichiers htaccess et htpdasswd ? et dans le dossier protégé je le met à la racine ou dans un sous dossier ?
- qu'apelles tu les fichiers distants ?
- le reste du contenu du dossier admin tu le renvois ou ?

Pour les photos j'ai trouvé, je sais pas pourquoi mais il y en a qui sont passées de .jpg à .JPG ...
enfin bon c'est réglé


Merci encore ;)

*** Message édité par jules34 le 13/06/2007 10:34 ***

Recharger l'url avec lien direct vers ce message Imprimer le message Aller en bas de page Aller en haut de page Editez ce post (réservé aux modérateurs) Avertissez l'administrateur si le post est non conventionnel Envoyer un email à jules34!!! Envoyer un Message Privé à jules34 Citer ce post dans votre réponse

 
 
admin

Nouveau

Enregistré le 20/05/2007
Messages: 26
Non connecté

Ajouté le : 14/06/2007 00:49
Message :

Oui désolé si je n'ai pas été clair, l'idée est d'envoyer d'abord le nécessaire pour protéger, et ensuite le contenu sensible à proteger. Evidemment tu peux aussi tout envoyer d'un coup dans ton dossier admin, mais tu prends le risque que certains fichiers soient pris dans le dossier pendant le transfert et/ou avant que tu aies réussi à mettre la protection en place.


Coup de pouce aux amis :
Votre site en page 1 sur Google
Autorépondeur gratuit et en français
Alerte twitter par mail
2 millions de visiteurs gratuitement pour votre site
Recharger l'url avec lien direct vers ce message Imprimer le message Aller en bas de page Aller en haut de page Editez ce post (réservé aux modérateurs) Avertissez l'administrateur si le post est non conventionnel Envoyer un email à admin!!! Visitez le site de admin!! Envoyer un Message Privé à admin Citer ce post dans votre réponse

 
 
jules34

Nouveau

Enregistré le 12/06/2007
Messages: 6
Non connecté

Ajouté le : 14/06/2007 08:55
Message :

je comprends pas pourtant je fais ce que tu m'as dis mais j'ai toujours le même problème : il me demande de retaper l'identifiant et le mot de passe.

J'ai sauvegardé les fichiers .htaccess et .htpasswd en .txt chacun puis je les ai transfèrer dans le dossier /security/admin que j'ai crée. Je les ai renommé et j'ai ensuite transfèrer le reste de mon dossier mais rien ne fonctionne.

Dans le .htpaccess mon AuthUserFile est du style : "/security/admin/.htpasswd".

Je sais pas ou se trouve le problème, c'est juste qu'il me dit que le login et le mot de passe n'est pas le bon.

Merci


édit : je sais pas s'il faut que le place mes fichiers dans le dossier security qui existe déjà ou bien dansle dossier public ?

*** Message édité par jules34 le 14/06/2007 09:14 ***

Recharger l'url avec lien direct vers ce message Imprimer le message Aller en bas de page Aller en haut de page Editez ce post (réservé aux modérateurs) Avertissez l'administrateur si le post est non conventionnel Envoyer un email à jules34!!! Envoyer un Message Privé à jules34 Citer ce post dans votre réponse

 
 
jules34

Nouveau

Enregistré le 12/06/2007
Messages: 6
Non connecté

Ajouté le : 14/06/2007 14:00
Message :

Voilà l'erreur que je reçois :

This server could not verify that you are authorized to access the document requested. Either you supplied the wrong credentials (e.g., bad password), or your browser doesn't understand how to supply the credentials required.


J'ai eu beau tout faire, je comprends pas pourquoi je n'ai pas accès à mon dossier.

Recharger l'url avec lien direct vers ce message Imprimer le message Aller en bas de page Aller en haut de page Editez ce post (réservé aux modérateurs) Avertissez l'administrateur si le post est non conventionnel Envoyer un email à jules34!!! Envoyer un Message Privé à jules34 Citer ce post dans votre réponse

 
 
jules34

Nouveau

Enregistré le 12/06/2007
Messages: 6
Non connecté

Ajouté le : 14/06/2007 14:38
Message :

Bon allez dernière post pour dire que j'ai réussi, enfin ...

C'était tout à fait autre chose, mon hébergeur c'est claranet et ils ont une autre manip pour utiliser les dossiers sécuriés. J'ai appelé le service technique et il m'a bien expliqué.

C'est bon merci pour avoir pris la peine de me répondre, à bientôt ;)

Recharger l'url avec lien direct vers ce message Imprimer le message Aller en bas de page Aller en haut de page Editez ce post (réservé aux modérateurs) Avertissez l'administrateur si le post est non conventionnel Envoyer un email à jules34!!! Envoyer un Message Privé à jules34 Citer ce post dans votre réponse

 
 
admin

Nouveau

Enregistré le 20/05/2007
Messages: 26
Non connecté

Ajouté le : 15/06/2007 11:12
Message :


C'est bon merci pour avoir pris la peine de me répondre, à bientôt ;)


Merci surtout d'avoir pris la peine de venir nous laisser ce témoignage, je suis sur qu'un jour ou l'autre un autre client claranet passera par ici et il sera tout content d'avoir la solution ;)


Coup de pouce aux amis :
Votre site en page 1 sur Google
Autorépondeur gratuit et en français
Alerte twitter par mail
2 millions de visiteurs gratuitement pour votre site
Recharger l'url avec lien direct vers ce message Imprimer le message Aller en bas de page Aller en haut de page Editez ce post (réservé aux modérateurs) Avertissez l'administrateur si le post est non conventionnel Envoyer un email à admin!!! Visitez le site de admin!! Envoyer un Message Privé à admin Citer ce post dans votre réponse

 
 
jules34

Nouveau

Enregistré le 12/06/2007
Messages: 6
Non connecté

Ajouté le : 15/06/2007 11:52
Message :

Clair vu comment j'ai galéré je vais éviter que tout le monde fasse comme moi ;)

Recharger l'url avec lien direct vers ce message Imprimer le message Aller en bas de page Aller en haut de page Editez ce post (réservé aux modérateurs) Avertissez l'administrateur si le post est non conventionnel Envoyer un email à jules34!!! Envoyer un Message Privé à jules34 Citer ce post dans votre réponse

 
 


<<Sujet précédent     Sujet suivant>>

 
[Contacter l'administrateur] | [Aller sur LeechFTP.eu]

 
[12 requêtes] - [Page générée en 0.0280 secondes]
 

Powered by CoolForum v.0.8.4 beta
Copyright ©2001-2006 CoolForum.net